Okay
  Public Ticket #1957461
PHP
Closed

Comments

  • Brad Grant started the conversation

    My ISP is scheduled to discontinue PHP support for versions prior 7, please see attached.

    I'm not sure what, if anything, I have to do to bring our site in compliance for compatibility.

    Thanks,

    Brad Grant

    (636)343-0170

    Attached files:  RE Important Notice PHP Upgrade.msg

  •  806
    Linh replied

    Hello

    Theme will work best with PHP v5.6. You can downgrade to that version or  you can hide it by turn debug off.

    define( 'WP_DEBUG', false );
    @ini_set( 'display_errors', 0 );

    The following code, inserted in your wp-config.php file.

    Thanks

  • Brad Grant replied

    Linh, thank you for the reply.

    Just to be clear, all I have to do is insert this code and it will make my Theme site backward-compatible with PHP 7.x ?

    Thanks,

    Brad

  •  806
    Linh replied

    Hello

    The warning message is show up because there are have changed php structure in the code with new PHP 7x but you don't worry, all the theme function will work normal. 

    So just use the code to hide all warning message then theme will work normal with PHP 7xx.

    Thanks